Static WordPress Community

Addons not showing

Hi folks,
Has anyone come across this?.. I installed wp2static from the latest source code, ran the composer install, etc. There was an error creating the wp_wp2static_addons db table because it complained that the primary key index size was too large – after some research I got around it by changing the char set to utf8 on the table. The server this is on uses MySQL 5.6, and it shouldn’t have been a problem on 5.7.

But now even with the table created it is not getting populated. I tried installing the S3 addon both from the download package for paid subscribers, and also tried building it from source. Either way, nothing shows on the ‘Addons’ page for the WP2Static admin configuration.

Any ideas?

Hi @ncrosno, thanks for finding that bug! It’s a fairly recent change and not in any published releases yet, so that’s good to catch now.

I think you may need to at least deactivate and reactivate plugin, possibly after dropping that table, too.

Let me know how that goes.

I haven’t tested the latest S3 addon with the latest master of core plugin for a while, but I think @john-shaffer has them both playing nicely and may be able to assist?

Thanks for the reply. De-activating and re-activating the s3 addon did not do anything. I’m more of a Ruby guy and not done much with WP plugins, but it kinda seems like the action to add the addon to the table is not firing.