Static WordPress Community

Cannot deploy to aws s3 : 500 error. But increasing max_execution_limit does nothing

Hello support,

I need helo with the error, which I have been facing while deploying to s3. I checked it by increasing execution time too. It’s throwing the same error.
image

Please help to resolve it.

Thanks
Sandip

Hi Sandip,

Were you previously able to deploy to S3 and now starting to see this error? If so, what may have changed in your site or server?

If this is your first time to try and seeing this error, please find your server’s error logs, they should provide more information about what error occurring.

If you can provide me some information about what kind of server you are using, I may be able to help you find the error logs. Else, if you have support available with your hosting, you may ask them to point you towards the webserver/PHP error logs.

Hi @leonstafford

Thanks for your response!

I am deploying it first time. I am using WPEngine hosted environment. Also, I checked with my localhost. Same error is showing while deploying. I am unable to attach error log file. Therefore I have posted image as below :
image

Looking forward to hearing back.

Thanks
Sandip

This sounds like an issue with the number of or configuration of rewrite rules in your .htaccess file.

If nothing unfamiliar there, I’d reach out to WPEngine support.

Otherwise, I’d try to clone the site to some other hosting, ie local computer, to see if it’s specific to the WPEngine environment.

Is this a WPEngine “staging” site, which is protected by http basic authentication? There was a bug with WP2Static working behind basic authentication, which has been fixed in latest code in GitHub repository and will be in next bundled release.

Hi @leonstafford

Thanks for your time!

I did the same thing. I have already disabled htaccess auth while running and deploying the WP2Static plugin. Also, I clone the site in my localhost. Its throwing the same error.

I have captured a video, Cannot deploy to aws s3 : 500 error. But increasing max_execution_limit does nothing If you want to see my localhost. I have pointed with vhost in local.

Thank you again!

Thanks for taking the time to do the screen recording, @sandip!

My next step would be to start with a completely new WP site, default theme, no plugins besides WP2Static and see if you still get the issue. I am hoping you don’t get the issue, then it’s not environmental, but something specific to your site, maybe a plugin or a wp-config.php setting or such.

(This is the best place for this kind of support. If you find a specific bug related to the plugin code, then that’s good to put in GitHub, but at this point, we’re still unsure what the cause is, so this support forum is good)

Hi @leonstafford

The Demo/Video which I have sent of my local Wordpress setup it does not have any plugin or any other themes, it’s the native theme and I have just installed the WP2Static plugin.

I have recorded a video again with more info, please have a look : Cannot deploy to aws s3 : 500 error. But increasing max_execution_limit does nothing

Please let me know if you want me to do any other steps.

Thank you
Sandip

Any new/feedback/updates ?

I have a deadline for the project. we had a plan to use this plugin which was fulfilling the requirement.

Earlier response would be appreciated.

Thanks
Sandip

Hi @leonstafford

Following up on this issue, Would you please give the direction to resolve it ?
We have 2 days left for launching the site.

Thanks
Sandip