Static WordPress Community

Can't get this to do anything properly!

I did manage to get a site export done using wp-cli (I think my script timeout was too low on the web… But I prefer wp-cli anyway).

However, I can’t any luck uploading to BunnyCDN. If I use the BunnyCDN option I get a stack trace;

BAD RESPONSE STATUS (401):
BUNNYCDN EXPORT: error encountered
Exception: BunnyCDN API bad response status in /var/www/vhosts/beardeddragonsrock.com/httpdocs/wp-content/plugins/static-html-output-plugin/plugin/deployers/BunnyCDN.php:2
Stack trace:
#0 /var/www/vhosts/beardeddragonsrock.com/httpdocs/wp-content/plugins/static-html-output-plugin/plugin/deployers/BunnyCDN.php(2): WP2Static_BunnyCDN->test_deploy()
#1 /var/www/vhosts/beardeddragonsrock.com/httpdocs/wp-content/plugins/static-html-output-plugin/plugin/deployers/BunnyCDN.php(2): WP2Static_BunnyCDN->__construct()
#2 /var/www/vhosts/beardeddragonsrock.com/httpdocs/wp-content/plugins/static-html-output-plugin/plugin/WP2Static/Dispatcher.php(2): require_once(’/var/www/vhosts…’)
#3 /var/www/vhosts/beardeddragonsrock.com/httpdocs/wp-content/plugins/static-html-output-plugin/wp2static.php(17): require_once(’/var/www/vhosts…’)
#4 /var/www/vhosts/beardeddragonsrock.com/httpdocs/wp-settings.php(371): include_once(’/var/www/vhosts…’)
#5 /var/www/vhosts/beardeddragonsrock.com/httpdocs/wp-config.php(88): require_once(’/var/www/vhosts…’)
#6 /var/www/vhosts/beardeddragonsrock.com/httpdocs/wp-load.php(37): require_once(’/var/www/vhosts…’)
#7 /var/www/vhosts/beardeddragonsrock.com/httpdocs/wp-admin/admin-ajax.php(22): require_once(’/var/www/vhosts…’)
#8 {main}

If I use the FTP option it just says ‘FAIL’ with no useable error message at all anywhere :frowning:
I’ve tested the BunnyCDN FTP credentials so I know they’re right.

Also, the BunnyCDN option DOES upload a file called tmpFile - so it is working - it just thinks it’s not!

Hoping someone can help!
Ta!
Steve