Static WordPress Community

Export taking too long to complete (More than 2 hours)

Hi there! Even with cache on, my Blog is taking too long to export the static. In the Export Log i can see the following:

2021-04-30 10:05:57 2021-04-30 01:05:57
PHP VERSION 7.3.27
OS VERSION Linux prd-web-blog-chart-name-regular-78c78994df-rxrpf 3.10.0-1127.19.1.el7.x86_64 #1 SMP Tue Aug 25 17:23:54 UTC 2020 x86_64
WP VERSION 5.6
WP URL
WP SITEURL
WP HOME
WP ADDRESS
PLUGIN VERSION 6.6.21
VIA WP-CLI?
STATIC EXPORT URL https://blog.web.intranet.com.br/
PERMALINK STRUCTURE /%postname%/
SERVER SOFTWARE Apache/2.4.38 (Debian)
2021-04-30 10:05:57 Active plugins:
2021-04-30 10:05:57 elementor/elementor.php
2021-04-30 10:05:58 prometheus-metrics-for-wp/prometheus-metrics-for-wp.php
2021-04-30 10:05:58 static-html-output/static-html-output-plugin.php
2021-04-30 10:05:58 Plugin options:
2021-04-30 10:05:58 additionalUrls:
/todos-os-posts/
2021-04-30 10:05:58 baseUrl:
2021-04-30 10:05:58 baseUrl-bitbucket:
2021-04-30 10:05:58 baseUrl-bunnycdn:
2021-04-30 10:05:58 baseUrl-github:
2021-04-30 10:05:58 baseUrl-gitlab:
2021-04-30 10:05:58 baseUrl-netlify:
2021-04-30 10:05:58 baseUrl-s3:
2021-04-30 10:05:58 baseUrl-zip:
2021-04-30 10:05:58 baseUrl-zip:
2021-04-30 10:05:58 basicAuthPassword: *******************
2021-04-30 10:05:58 basicAuthUser:
2021-04-30 10:05:58 bbBranch:
2021-04-30 10:05:58 bbRepo:
2021-04-30 10:05:58 bbToken: *******************
2021-04-30 10:05:58 bunnycdnStorageZoneAccessKey: *******************
2021-04-30 10:05:58 bunnycdnPullZoneAccessKey: *******************
2021-04-30 10:05:58 bunnycdnPullZoneID:
2021-04-30 10:05:58 bunnycdnStorageZoneName:
2021-04-30 10:05:58 bunnycdn_api_host: *******************
2021-04-30 10:05:58 cfDistributionId:
2021-04-30 10:05:58 completionEmail:
2021-04-30 10:05:58 crawl_delay: 0
2021-04-30 10:05:58 crawl_increment: 50
2021-04-30 10:05:58 crawlPort:
2021-04-30 10:05:58 delayBetweenAPICalls: 0
2021-04-30 10:05:58 deployBatchSize: 50
2021-04-30 10:05:58 excludeURLs:
2021-04-30 10:05:58 ghBranch:
2021-04-30 10:05:58 ghCommitMessage:
2021-04-30 10:05:58 ghRepo:
2021-04-30 10:05:58 ghToken: *******************
2021-04-30 10:05:58 glBranch:
2021-04-30 10:05:58 glProject:
2021-04-30 10:05:58 glToken: *******************
2021-04-30 10:05:58 netlifyHeaders:
2021-04-30 10:05:58 netlifyPersonalAccessToken: *******************
2021-04-30 10:05:58 netlifyRedirects:
2021-04-30 10:05:58 netlifySiteID:
2021-04-30 10:05:58 removeConditionalHeadComments: 1
2021-04-30 10:05:58 removeHTMLComments: 1
2021-04-30 10:05:58 removeWPLinks: 1
2021-04-30 10:05:58 removeWPMeta: 1
2021-04-30 10:05:58 rewrite_rules:
2021-04-30 10:05:58 rename_rules:
2021-04-30 10:05:58 s3Bucket:
2021-04-30 10:05:58 s3Key:
2021-04-30 10:05:58 s3Region:
2021-04-30 10:05:58 s3Secret: *******************
2021-04-30 10:05:58 selected_deployment_option: zip
2021-04-30 10:05:58 targetFolder:
2021-04-30 10:05:58 useBasicAuth:
2021-04-30 10:05:58 Installed extensions:
2021-04-30 10:05:58 Core,date,libxml,openssl,pcre,sqlite3,zlib,ctype,curl,dom,fileinfo,filter,ftp,hash,iconv,json,mbstring,SPL,PDO,session,posix,Reflection,standard,SimpleXML,pdo_sqlite,Phar,tokenizer,xml,xmlreader,xmlwriter,mysqlnd,apache2handler,bcmath,exif,gd,imagick,mysqli,sodium,zip,Zend OPcache
2021-04-30 10:08:37 cURL error:OpenSSL SSL_connect: SSL_ERROR_SYSCALL in connection to blog.web.intranet.com.br:443
2021-04-30 10:08:37 BAD RESPONSE STATUS (0): /2021/04/27/

The BAD RESPONSE occurs on several links.

Thank you guys for the support!

Como vais, @paulotcampos,

Sorry for slow reply.

Is this by chance a self-signed TLS certificate to provide https on your site? Ideally, the dev site will not be publicly accessible, so serving without TLS (just http) may help there.

Not sure if that’s the only issue causing your export to fail, but you may also try bumping to PHP 7.4.