Static WordPress Community

Netlify Deployment Stuck on "Uploading"

Hi there, I am using WP2Static version 7-alpha (with Netlify add-on), and I’ve set up my back-end and queued the jobs. All the jobs successfully complete, except for Deployment, which remains processing. When I check the Netlify back-end it says Uploading for the latest production build, and “There is no log for this deploy” in the Deploy details. It stays like this for over 15-20 minutes, even up to 45 minutes, and I end up canceling the deploy.

I have tried multiple deploys and I have tried making sure all the file sizes are small. No success.

Could you help me out?

Thank you.

Hi and welcome, @citizenerased~! Hmm, does sound odd.

Temporary workaround/troubleshooting step is to export as a zip and then either drag and drop to the Netlify UI or use their CLI tool (preferred). There have been some changes to the Netlify web UI, where you may not be able to drag/drop a zip if the site was previously deployed using another method.

The Netlify CLI tool is the closest to using WP2Static V7’s Netlify deploy, so that’s preferred vs zip for the point of troubleshooting this.

If it does deploy fine using their tool, then there’s an issue with the way the plugin’s deploying, your API details or it may be choking on a particular file within the deployment. There may be some server error logs from the time of deployment which will help us more then.

So, my suggested steps:

  • zip deployment, download that
  • extract the zip contents to your local computer
  • run the Netlify CLI tool to deploy that folder
  • if that runs OK, let’s look for an error in your server logs when deploying to Netlify via WP2Static
  • if it fails using Netlify CLI tool, it may be the content of the site. Try again with an empty WordPress site, default theme, etc

Thanks for your response.

I tried using Zip deployment, and it worked well.
(I downloaded the zip, copied the contents over to my git, and deployed to netlify without any build commands)

I did notice that author archive pages and audio files did not play on the static website. I am surprised about the audio files not working (seriously simple podcasting plugin). I wonder if that is because I did not deploy using any build commands (ie: CLI tool)?

Direct Netlify deploy via WP2Static still not working for me, but at least I was able to get a temporary solution.

Any word on a timeline for stable release of v7.0?

Thanks again!

Hi @citizenerased,

Great, glad you got it exported, albeit with a workaround.

Re deadlines and some of the issues mentioned, I’ve been focusing on cleaning up a bunch of issues in V6 before focusing on V7 again. Author links were fixed there and I’ve added an issue re audio to V6 to track and an issue in V7 to get the author URLs sorted (there’s a few other URL detection issues solved in V6 that I’ll bring across into V7 soon).

Things work a little different for audio files in V7. Could you please let me know what file extensions these audio files have?

Here’s my bit on estimates re official release expectations. How my mind’s thinking of it at the moment:

  • get last few V6 bugs squashed
  • get minimal docs on new V6 site (statichtmloutput.com)
  • get some automated test coverage in place for V7
  • apply detection fixes to V7
  • add URL discovery during crawl to V7
  • get a few key V7 add-ons stable

As I’ve already been sharing V7 builds and it’s not on wordpress.org yet, I don’t mind sending out more pre-release builds of that. With V6, I have no lines of communication with people who download from wp.org/WP dashboard, so I want to try not to push out next V6 release with any major issues. Not much left to do on V6, so hopefully that’s ready around this weekend (linked to my productivity).

PS. for the audio files, at least, if you open up your browser’s console to the Network tab on the static site and reload the page, it should list all the 404’s/files that failed to load. If you manually copy over the original audio files to that dir when deploying, that should solve it temporarily.