Static WordPress Community

WP2Static Premium version won't run at all

I was using the free version of WP2Static, and it worked sometimes, but had some issues. I decided to pay for the Premium version 7.0-alpha-007. After installing it and manually starting a job, everything just sits in “Waiting” status and never starts. All of the caches have 0 URLs in them. I’ve tried uninstalling and re-installing and I get the same results. Nothing ever happens, just stuck at “waiting” for hours.

Anyone else had this problem?

Few tips

  • Install one addon (zip/netlify) as well
  • In Jobs page, set automation to 1 min
  • Visit /wp-cron.php or click on manually start the task
  • It should run. If not check your HTTP web server access.log and error.log
  • If you are using HTTP auth, you need to set.
  • Check web firewall log if any you have.

Thanks for the feedback gulshan.

I’ve done all of the above and still stuck in waiting. However in diagnostic tab my php_max_execution is 300 instead of unlimited, but my host won’t allow me to go unlimited. Even with it at 300 it should still run though right? Even if it does time out later.

I want to give you a rough idea –

For a site with 2000 & pages posts, I’d prefer keeping max_execution_time 1800 minimum.

If your hosting doesn’t allow changing, you can create own Staging Environment.

Thanks for the info. Unfortunately running this locally isn’t an option as we have a team of people that work on the site. Migrating it may be a possibility, but I really don’t want to go through the hassle of migrating only to have the same thing happen.

I’m just really confused why it won’t even attempt to start a job, even when I only check “Detect” and exclude all other job types. Shouldn’t it at least be able to start a Detecting job instead of being stuck in Waiting?

Is there a previous version before 7.0? Or a place for a refund?

To know cause, consider checking server side log. All hosting provider offers a way to check access.log and error.log

Sidenote: make sure you are using latest php version

For refund related queries, please message @leonstafford

I spun up a clean, brand-new EC2 instance with the WordPress AMI. Logged in for the first time, installed wp2static-7.0-alpha-007.zip, then installed wp2static-addon-zip-1.0-alpha-005.zip. All diagnostics are showing green check marks.

Same thing. I manually enqueue jobs and they all get stuck at waiting. Refresh. Still waiting. Nothing ever happens. This is a completely brand new Wordpress Instance.

I can’t be the only person having this issue. Am I installing the wrong version? Is alpha-007 the newest version? Is there a stable version instead of alpha?

Same thing happening here. Just bought the Premium version (7.0-alpha-007) and stuck on Waiting when trying to manually trigger the jobs. Running it locally with Mamp. All health checks are green. Latest version of WP. No additional plugins.

I also want a refund if this is not adressed asap.

Yep, been wasting my time with this… Kindly fix.

Which Operating System do you use?

  • Windows is not supported. Consider using Mac/Linux.

I’ve tried this on Linux and Mac with no success on either. Haven’t even tried Windows.

Try this version 6.6.21

It works fine with ZIP, Netlify and BunnyCDN as per my test.

You can test it over Docker as well

6.6.21 is the only version I’ve been able to get to do anything with but it doesn’t have the webhooks I was looking for in the new version.

This should be fixed in the latest git build. If you have git and composer installed, you can run this from your plugins directory:

rm -rf wp2static
git clone https://github.com/WP2Static/wp2static.git
cd wp2static
git checkout b3e08f5da9ceaafbebf86d434879600393fe7449
composer install

I’ve mentioned the issue to Leon, so hopefully he can get a new build out soon.